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1. Introduction

1.     Introduction

Welcome to the ON-AIR Designer, Lawo's software application for configuring radio on-air systems.

About this Manual

This manual describes how to use the ON-AIR Designer. It covers the operation of the software only. How to
configure specific products is covered in the relevant product manuals. The specification is valid for Version
6.0.0.x.

Note that the software is used to configure a range of systems, and so screenshots from different products are
used to illustrate this manual.

All Lawo manuals are available from the Download-Center at www.lawo.com (after Login).

Look out for the following which indicate:

Notes - points of clarification.

Tips - useful tips and short cuts.

WARNINGS: Alert you when an action should always be observed!

Lawo User Registration

For access to the Download-Center and to receive regular product updates, please register at:

www.lawo.com/user-registration.

http://www.lawo.com
http://www.lawo.com/user-registration
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2. Overview

2.     Overview

What is the System Configuration?

The system configuration is created offline using a software application called the ON-AIR Designer. It defines
key aspects of the system such as:

· Input and Output naming – each input and output is named to clearly identify connections to external
equipment.

· Sources – each source is named and defined to be mono, stereo, 5.1, 5.1/2ch; or used as a MIDI control
channel to work with DAWs (like ProTools™); or as a VCA group to control other faders.

· Summing Busses – each summing bus is named and defined to be mono, stereo or 5.1. 

· Signal Processing – EQ, Dynamics, Limiter and Delay are available for all sources, and some or all
summing busses depending on the available resources. In addition, a pool of De-Esser and AutoMix
processing may be configured for any mono or stereo source.

· Control Surface Layout – the configuration defines which sources are available for fader strip
assignment, and whether the console can be switched to access layers and/or virtual Fader Modules.

· MF (Multi-Function) Keys – the configuration defines the function and colour coding applied to all MF
Keys. MF Keys are available on the control surface modules, VisTool displays and external Key Panels.

· External Control Functions – the configuration also defines how the console responds to external
control functions such as GPI signals or radio automation systems.

· Logic Elements – these elements are used to program logical functions. For example, if you need a
function to be triggered by the result of a number of other conditions. Logic elements include OR, AND,
NOT, etc.

· Connects – "Connect" elements may be configured to control audio connection between inputs and
outputs. For example, to create a communications system or routing matrix.

· Minimixer – this is a stereo-in-stereo-out mix element designed principally for use within the monitor
chain of the system. Minimixers offer level control, dim, balance, phase reverse, etc.

Where is the Configuration Stored?

During editing, each project is stored on your computer (as a .db3 file). Whenever you transfer a project to the
DSP Core, the .db3 datatbase is first compiled to create a binary .cfg file that can be read by the system. It is
this file which is read by the DSP Core in order to load the configuration. The binary version is non-editable and
cannot be opened by the ON-AIR Designer. Therefore, it is recommended to maintain the .db3 file on your PC to
allow for changes and additions.

Note that the following products allow you to store an editable version on the DSP Core hardware:

· POWER CORE (710/10)

· Nova17 MKII (947/62 & 947/65)

All other products store the binary .cfg version only.

Once transferred, the configuration resides within the DSP Core's control system and is loaded at the end of boot-
up.

Modifying the Configuration

The simplest way to customise a system is to modify the existing configuration or a standard template. To do
this, you will need a copy of the latest configuration or template as a .db3 file. You can then use the ON-AIR
Designer software to open, edit and save the file; and transfer the modified configuration back to the system.

If you wish to make lots of modifications, then it is best to plan out exactly what you want BEFORE you start
programming - IO names, signal flow, MF Key functions, etc. This is particularly important where multiple
systems are networked together, as you will want to provide consistent operation across the installation.
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Integrating VisTool

If you plan to install VisTool(s), it is a good idea to create the VisTool and system configurations in parallel, and
check the results step-by-step. Please refer to the separate "VisTool MK2 User Guide" for more details on using
VisTool Edit to edit the VisTool project.

What's New?

The ON-AIR Designer includes the following features (not available in the previous config tool "zirkon.exe"):

· Speed and Flexibility - the new software is much faster to work with and can open multiple projects
simultaneously.

· Configuring Multiple Units - you can configure multiple units of the same product in one project. This
makes it easy to maintain the configuration as, if something changes, the change need only be applied
once. Once multiple units have been defined, the substitutions feature can be used to individualize certain
parameters.

· Global Project - can store global settings, such as metering schemes, so that they may be applied to
multiple projects.

· Docking Options & Tabbed View - help to organize the workspace.

Backwards Compatibility

Configurations designed using the previous config tool "zirkon.exe" are compatible with the ON-AIR Designer,
and can be used without restrictions. Hence, the ON-AIR Designer supports two project file types:

· .db3 - is the new file type supported by systems running Version 6.0.0.x or later.

· .mdb - is the previous file type used by "zirkon.exe", and is required for systems < Version 6.0.0.x.

.db3 is recommended, as .mdb files do NOT support substitutions, and the software's operation is slower when
loading and saving data as .mdb.

.mdb configurations can be opened and will be automatically updated so that they can be stored using the new

.db3 file format.

Please note that the modification of a configuration for the product Zirkon is no longer supported (as of the Version
6.0.0.x release).
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3.     Installation

This chapter describes how to install the software and connect your computer to the Lawo system.

Topics include:

· PC Requirements

· Installing the Software

· Updating the OnAir Designer

· Windows Setting

· Connecting Your PC to the Lawo Control System
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3. Installation

3.1 PC Requirements

To install and run the ON-AIR Designer, your PC MUST meet or exceed the following requirements:

· Windows 7, 8 or higher operating system.

· Core-i5 processor or higher.

· 2GB RAM (minimum)
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3.2 Installing the Software

The onair-designer.exe file performs an automatic install of the ON-AIR Designer and SoP Explorer.

1. Copy the installer onto your computer.

2. Double click on the installer icon - this starts the ‘ON-AIR Designer Setup Wizard’:

3. Follow the Wizard's instructions accepting the default options provided.

4. When you reach the 'Summary' window, check the options and click Install - the software is installed
onto your computer; this may take a few minutes.

By default, files are installed in the location: ‘C:\Program Files\OnAirDesigner’.

5. When the installation is complete, the following window will appear:

6. Click on Finish to exit the ‘Setup Wizard’.

If you have any problems with the software installation, please contact your local Lawo representative or email
support@lawo.com.

mailto:support@lawo.com
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3.3 Updating the ON-AIR Designer

All configurable features of Lawo's On-Air products are maintained in a so called "definition" database which is
updated with every new release. It is mandatory that the software version your system matches the version of the
configuration tool to ensure proper functionality. Otherwise the configuration may contain options which are not
supported by the Lawo system (and the configuration will not be read). 

When a new release is issued, the following components are automatically installed by the onair-designer.exe
file:

· ON-AIR Designer - the latest release of the ON-AIR Designer software.

· System Firmware - the new system software files to match the ON-AIR Designer definition.

· SoP Explorer - Lawo's software update tool for updating all components of the system.

There is no need to uninstall the older version of ON-AIR Designer before running a new installer.

To make sure everything runs smoothly, first run the installer (to update the ON-AIR Designer) and then use SoP
Explorer to check and update each of the Lawo system components. You will find more details on SoP
Explorer in your system's User Manual.

Once both the system and ON-AIR Designer are running the same release, you can then open (and convert) the
configuration project to take advantage of any new options and features.

Note that when you open a project created using an earlier definition, you can choose whether to convert the
project or not. This allows you to maintain configurations for systems running different versions. See Converting
Projects.
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3.4 Windows Setting

To display the correct color-coding for the software's reference fields, the Windows setting: "Animate controls
and elements inside windows" must be disabled. Otherwise, you will not see the correct color change when
using a mouse over.

Windows 8 - Advanced System Properties
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3. Installation

3.5 Connecting Your PC to the Lawo Control System

You can start the software and edit a project offline. However, at some point you will need to connect your
computer to the Lawo control system network in order to transfer the configuration data. To do this:

1. Connect the ON-AIR Designer PC to the Lawo control system's ETHERNET port, either directly or via a
network switch.

Do NOT use an Ethernet hub as this will interrupt the data stream. 

2. Configure the TCP/IP settings on your computer's Network Interface Card.

For details on which ETHERNET port and TCP/IP settings to use, please refer to the user manual for your DSP
Core/Router.

You can check the network communication later once you have started the software and opened a project, see 
Checking the Network Communication.
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4. Basic Operations

4.     Basic Operations

This chapter describes the basic operating principles of the software.

Topics include:

· Starting the Application

· File -> New

· File -> Open

· Saving the Project

· The Main Operating Windows

· Arranging the Workspace

· The Main Menus

· Toolbar

· ‘Project’ Window

· Checking the Network Communication

· Options

· Closing the Project & Software
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4. Basic Operations

4.1 Starting the Application

1. On your PC, select START -> Program Files -> OnAirDesigner -> ON-AIR Designer:

Windows Start Menu

This is the default file path created during a standard install.

The application opens with a blank operating window:

At the top of the page you will find the main menus and toolbar. 

To start working with the software, you can either create a new project or open an existing one.
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4.2 File -> New

To create a new project:

1. Select File -> New from the top menu bar, or click on the  Toolbar icon, or use the keyboard shortcut
(CTRL + N) - the 'New Project Wizard' opens:

2. Select a product and click on Next.

3. The next step varies depending on the product.

For ruby and sapphire/Nova17, skip straight to step 4. For crystal, Nova29 and sapphire compact, you have
the opportunity to select a template:

crystal - Templates choice

· Choose one of the template options to open a standard configuration (recommended).

· Or, choose option 0 – Frame Selection to configure the "frames" manually (as described in step 4).

Usually it is best to choose a template, as this will automatically configure some of the main system elements:
inputs, outputs, sources and summing busses. If you choose option 0, then all elements must be programmed
from scratch.

Note that the Nova29 supports two template options only:

· 1 - nova29, no default names - defines a simple configuration with MADI ports 1 to 16 set for 64-slot
transmission and no redundancy. Sync options are set for internal sync and 48kHz operation.

· 2 - nova29, with default names - as above but with default names for the MADI inputs and outputs.
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4. If you selected option 0, or are configuring a ruby or sapphire/Nova17, then the 'Frame' options must be
defined manually.

Note that the following window does not appear if you selected a template (in step 3).

ruby - Frame selection

The four 'Frame' areas define the System Core, Surface, Panels and Screen:

· System Core = the DSP Core, available in three licensed packages that affect the number of resources.

· Surface = the maximum control surface size, where the numbers in brackets indicate the number of
Fader Modules + Central Module + Central Modules running in monitor mode.

· Panels = the maximum number of Key Panels connected to the system.

· Screen is always set to Screen functions to support VisTool functions.

For the System Core, please select the licensed package which has been purchased.

For the Surface, select the maximum configuration required. For example, the ruby 16 Fader (4+1) option can
be used for a 4-, 8-, 12- or 16-fader surface with a single Central Module. If more faders are fitted, or you have
more than one Central Module (running in monitor mode), then a larger Surface option must be used.

Note that the specification can be changed later (via Frame -> Change Frame). So, for example, if you upgrade
the licensed package for your DSP Core, you can change the System Core frame to unlock the additional
resources.
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5. Once you have selected a template or specified the 'Frame' , click on Finish. 

The software creates the new configuration. Depending on the product and its specification, a number of windows
will open. In our example, we can see the 'Project' window (on the left), plus the 'System Core' (in the central
working area):

ruby New Configuration

Note that it may take a few seconds to build the new project. During this time the status is shown in the
"progress" bar (below Console in the 'Project' window).

The next logical step is to define the properties in the 'Project' window.
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4.3 File -> Open

To open an existing project stored on your computer:

1. Select File -> Open from the top menu bar, or click on the  Toolbar icon, or use the keyboard
shortcut (CTRL + O).

2. Select your project file and click on Open.

If you cannot see the file, check the Files of type option at the bottom of the dialog box; you may need to
change this to see the correct file type (.db3 or .mdb).

The project opens, with the same workspace layout and docking options as at the last file save:

If the configuration was created using a different definition version, then you may be asked if you wish to convert
the project. Note that it may take a few seconds to open the project. During this time the status is shown in the
"progress" bar (below Console in the 'Project' window).

If you see an error stating that the project is already open then navigate to the project folder (using Windows
Explorer) and delete any .txt files. Then try opening the project again.

On POWER CORE and Nova17, a copy of the project file can be stored on the DSP Core. To download it to
your computer, use Load Project from unit.
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4.3.1 Converting Projects to the Current Release

When you save a configuration, the definition version of the ON-AIR Designer is stored along with the project in
the same folder (in a file named projectname.def). This means that when you open a project, the versions can
be compared.

If a project was created using an earlier definition, then you will be asked if you wish to convert the project:

Select Yes to proceed, or No to work with the older version. (You will need to choose No if the system you are
configuring is running an older version of software.)

If you select "don't show this message again" then, in future, this message will not appear, and projects will
automatically convert to the current ON-AIR Designer release. This will speed up all subsequent "File -> Open"
operations. You can re-activate the message later from the software Options - use the Show convert message
tickbox (under the General tab):

By leaving the message enabled, you will be able to choose Yes to convert some projects and No for others (to
configure systems running a different software release).

Note that whenever a project is converted, the software creates a copy of the original file (before conversion) and
stores this in the project folder (using the suffix "_before_convert"). This allows you to re-open the original project
if necessary:
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4.4 Saving the Project

At regular intervals you should save the project, and also use "save as" to keep a copy of the project at different
revision stages. This will allow you to test the configuration and revert to an earlier version if necessary.

Ø  File -> Save

Select File -> Save from the top menu bar, or click on the  Toolbar icon, or use the keyboard shortcut (CTRL
+ S).

This overwrites the existing project (as specified in the "File" field in ‘Project’ window):

Ø  File -> Save As

1. Select File -> Save As from the top menu bar, or use the keyboard shortcut (CTRL + SHIFT + S) - the
"Save" dialogue box opens:

2. Choose a new folder location, enter a different file name, or select a different file type (using the Files of
type option at the bottom of the dialog box).

3. Then click on Save to save the project:

The default file type is .db3 unless you specify otherwise. See Backwards Compatibility.

Note that a project containing substitutions cannot be saved as a .mdb file.
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4.5 The Main Operating Windows

To edit the configuration, there are several windows and menu options you will use:

 1   Project

The 'Project' window defines the main properties for the system such as its IP-Address and CAN bus speed. It
can also be used to add multiple units to the project (to work with substitutions).

 2   Frames

Each of the four main 'Frame' windows defines a system component: the System Core, Control Surface, Key
Panels and Screen (for VisTool functions). In each case, you will see a graphical representation - in our example,
of the System Core. Double-click on the images to configure the relevant options - for example, to define a
connector's inputs and outputs or add an expansion card.

 3   Tree Definition

From the 'Tree Definition' you can specify all the elements of the system, from sources and busses to MF Keys
and logical functions. The 'Tree Definition' gets its name from the tree-like structure on its left hand side. Each of
the branches can be opened by double-clicking on a branch name or on the arrows beside the branch. Once
open, you will see all the available parameters for the selected element - in our example, for a Source named MIC
1.

 4   Command -> Resources

This window can be used to check the amount of DSP resource used by the project. Note that the resource
counters will vary depending on the System Core frame selection.

 5   Substitutions

If you are configuring more than one unit, then you can open the 'Local' and 'Global' substitution windows to 
individualize parameters as required. Note that with the other configuration windows, a substituted parameter is
indicated by a grey background.
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 6   Function Pool (ruby only)

The 'Function Pool' is only available for ruby. It can be used to prepare MF Keys before positioning them on a
Central Module, or to move a function by swapping it to and from the 'Function Pool' panel.

This is ideal if you know what functionality is required, but are not yet sure of the MF Key layout.

 7   Transfer

The Transfer menu is used to transfer data from your computer to the Lawo system. You can choose to transfer
"Setup" data (the TCP/IP configuration) and/or the "Config" data (the configuration itself).
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4.6 Arranging the Workspace

The workspace includes four docking areas (left, right, top and bottom), plus a central working area where
configuration windows can be either floating or stacked. Note that when you save a project, you will save the
current layout.

In the example below, the open panels are all docked (shown in blue), and the central workspace is using floating
windows (shown in red):

1. Click and drag on a boundary edge to increase or decrease the size of a space. In the example below the
height of the bottom docking area has been increased:
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4.6.1 Docking Panels

Each of the following panels can be docked, floating or hidden from view:

Toolbar icon (to show/hide) Docking Positions

The 'Project' window Left or Right

'Function Pool' Left or Right

'Global Substitutions' Top or Bottom

'Local Substitutions' Top or Bottom

'Jump to' n/a (selected via context menu) Left, Right, Top or Bottom

'Parameter Line' n/a (selected via context menu) Left, Right, Top or Bottom

To change the current location or behaviour:

1. Click and drag on the panel's headline bar to release it from the docking area.

2. Then do one of the following:

· To create a floating window, release the panel anywhere above the workspace. The panel becomes a
floating window which can be resized and positioned in the usual manner. If you lose a panel from view,

click on the  Toolbar icon to re-dock all panels (to their last docked positions).

· To dock the panel in a new position, release it into a different docking area (left or right, top or bottom).
Note that not all panels can be docked in all positions, so a blue background appears when a valid area is
reached. When you release the panel, it will fill the available space.

'Project' window - moved from left to right

More than one panel can share a docking space. This allows you to position the 'Project' and 'Function Pool'
above and below each other. Or, the 'Global' and 'Local' substitutions above and below, or side by side.
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4.6.2 Tabbed View

Each of the remaining configuration windows appear in the central workspace. They can be opened and closed
using either a toolbar icon or main menu option. Note that the 'Tree Definition' can be opened multiple times (to
access different branches of the system tree). All open windows can be either stacked (in Tabbed View) or
floating (Tabbed View off).

1. Click on the  Toolbar icon, or select Window -> Tabbed View, the change the view.

In Tabbed View, all open windows are stacked. Use the tabs at the top of the workspace to switch between
them - the selected window fills the central workspace. Note that you can click and drag on the tabs themselves
to change their order if you wish.

Central Workspace: Tabbed View
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If Tabbed View is not selected, then all open windows are floating. A floating window can be resized and
positioned anywhere in the central workspace:

· Click and drag on the headline bar (at the top of the window) to move it.

· Click and drag on the left, right or bottom boundary lines to resize.

· Click on the buttons at the top right to minimise, maximise or close a window.

Central Workspace: Floating Windows

If you lose a floating window from view, then either minimise all visible windows, or select Window -> Cascade or
Window -> Tile to re-arrange the view.
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4.7 The Main Menus

4.7.1 File

Use the File menu to:

· New - create a new project (.db3 file)

· Open - open an existing project.

· Close - close the active project.

· Recently opened Files - lists all the recently saved projects; click to open one.

· Load Project from unit - loads a project stored on the unit (only available when Online).

· Project History - shows the history of the project file:

o Database - the version of the project file.

o Program - the ON-AIR Designer software version used to create the file.

o Changed - the date when the configuration file was last saved.

· Save and Save as - Save a configuration.

· Find - perform a search on the 'Tree Definition' window.

· Exit - quit the ON-AIR Designer software.

4.7.2 Edit

Use the Edit menu to:

· Add unit / Delete Unit - add or delete a unit from the project, see Configuring Multiple Units in a Project.
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4.7.3 View

Use the View menu to:

· Toolbar – show or hide the Toolbar.

· Statusbar – show or hide the Console status area at the bottom of the 'Project' window.

· Style – select a display style.

· Refresh – refresh the screen.

· Options – open the options dialogue box.

· Userlevel – select a user level to access different configuration options.

· Units – select a unit (if multiple units have been defined).

· Profile – select a profile (if profiles have been loaded from the Global project). If no Profiles exist, or a
Global project has not been specified, then there is nothing to select.

4.7.4 Frame

Use the Frame menu to:

· Show all Hardware - show (or hide) unused panels or surfaces for a better overview of the configured
hardware.

· Function Pool - show (or hide) the Function Pool.

· Change Frame - change the frame specification.

· System Core - show (or hide) the DSP Core.

· Surface - show (or hide) the control surface modules.

· Panels - show (or hide) any optional Key Panels.

· Screen - show (or hide) any ‘virtual’ panels which will be operated via VisTool.
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4.7.5 Command

Use the Command menu to:

· Parameter – open the parameter window for the selected frame module.

· Resources – open the 'Resources' window.

· Treedefinition – opens a ‘Tree Definition’ window.

· Sort Tree – when ticked, elements within the ‘Tree Definition’ window are sorted alphabetically.

· Find - perform a search on the 'Tree Definition' window.

· Inputs / Outputs – open the Inputs or Outputs list.

· Device Configuration Wizard - open the device configuration wizard.

4.7.6 Transfer

Use the Transfer menu to:

· Config to unit - transfer the active configuration to the unit.

· Setup to unit - transfer the ‘Setup’ parameters to the unit.

· Create Config – create the binary configuration without performing a transfer.

4.7.7 Window

Use the Window menu to:

· Dock Tools - reset all panels to their last known docking positions.

· Tabbed View - switch between Tabbed View and floating windows.

· Cascade / Tile - control the view when using floating windows.

· 1, 2, ... - all open windows are listed in the lower part of the menu. If a window has been minimised or
hidden, then click on its name to bring it back into view.
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4.7.8 ? (Help)

Select Info to check the release version of the ON-AIR Designer.
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4.8 Toolbar

The toolbar icons provide fast access to a number of functions. If you cannot see the toolbar, then check that is
enabled in the View menu.

The first few icons perform file-based operations:

Exit - close the ON-AIR Designer software (same as File -> Exit).

New - create a new configuration (same as File -> New).

Open - open an existing configuration (same as File -> Open).

Save - save the current configuration to your PC (same as File -> Save).

Project - show/hide the 'Project' window.

Close - close the current configuration (same as File -> Close).

The next set of icons define the software's options and views:

Options - open the Options dialogue box (same as View -> Options).

Tabbed View - switch the view (same as Window -> Tabbed View).

Dock Tools - reset all panels to their last known docking positions (same as Window -> Dock Tools).

The next series of icons provide fast access to different aspects of the configuration:

System Core - show/hide the 'System Core' window (same as Frame -> System Core).

Surface - show/hide the 'Surface' window (same as Frame -> Surface).

Panels - show/hide the 'Panels' window (same as Frame -> Panels).

Screen - show/hide the 'Screen' window (same as Frame -> Screen).

Function Pool - show/hide the 'Function Pool' (same as Frame -> Function Pool).

Show all Hardware - show/hide any unused panels or surfaces for a better overview of the configured
hardware (same as Frame -> Show all Hardware). 

Change Frame - open the 'change frame' window (same as Frame -> Change Frame).

Treedefinition - open a new 'Tree Definition' window (same as Command -> Treedefinition). Note that if
you click on the icon more than once, then multiple windows will open.
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The remaining icons are:

Inputs - open the Inputs list (same as Command -> Inputs).

Outputs - open the Outputs list (same as Command -> Outputs).

User Level - select a user level to access different configuration options (same as View -> User Level).

Device Configuration Wizard - open the device configuration wizard.

Local Substitutions - open the 'Local Substitutions' window.

Units - click to select a unit (if multiple units have been defined); all windows update to show the
parameter values for the selected unit.

Global Substitutions - open the 'Global Substitutions' window.

Profile - click to select a profile (if profiles have been loaded from the Global project). If no Profiles exist,
or a Global project has not been specified, then there is nothing to select.

Create config - click to create the binary configuration (same as Transfer -> Create Config).

Config to Unit - click to transfer the active configuration to the unit (same as Transfer -> Config to Unit).
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4.9 ‘Project’ Window

The 'Project' window defines the main properties for the system.  It can also be used to make an Online
connection to the Lawo control system, and see the progress of operations such as load, save and transfer.

1. Click on the  Toolbar icon to show or hide the 'Project' window.

The window can be floating or docked to one side (left or right). See Arranging the Workspace.

The 'Project' Window
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If you have opened an existing configuration, then most of the properties should be complete. If you have created
a new configuration, then many of the fields will be empty:

'Project' Window - completed 'Project' Window - new

General Properties

Each of the property fields should be completed as follows.

Note that if you are configuring more than one unit, then any substituted fields are indicated by a grey
background. These cannot be edited directly, but should be entered individually for each unit from the
'Substitution' windows.

· Product - this line is completed automatically. It shows the product type (selected when the configuration
was created using File -> New).

· File - this line is completed automatically when you save the project. It shows the file path where the
project is stored. Use File -> Save As to change the file name or location.

· Global project (optional) - click to define a Global project (to apply global settings such as metering
schemes).

· Profiles (optional) - this area lists any Profiles stored in the Global project. If no Profiles exist, or a Global
project has not been specified, then the area remains blank.

· Units - you can configure multiple units of the same product type in one project. Right-click to Add or
Delete a unit; then use this field to switch between units. By default, a configuration change is applied to
all units in parallel. If this is not desirable, then use the substitutions feature to individualize the required
parameters.

· Name - enter a project title, for example NAB ruby.

· Deskname - enter a desk name to identify the unit, for example ruby02. This name is transferred to the
Lawo control system when you use Transfer -> Setup to Unit.
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· Author (optional) - enter the name of the configuration author.

· User - this line is completed automatically. It shows the registered user of the configuration PC (for
information purposes).

· PC IP-Address - this line is completed automatically. It shows the IP address of the configuration PC
(useful for avoiding IP conflicts).

· Template - this line is completed automatically. It shows the name of the template (selected when the
configuration was created using File -> New).

· Can speed - enter the CAN bus speed for the system. The default is 500K. Note that this MUST match
the CAN bus speed stored on each control surface module.

· Coldstart - this line is completed automatically. It shows whether the system will perform a warm start or
cold start after a transfer of configuration data. For crystal, sapphire compact, sapphire/Nova17 and
ruby, the option is ticked (i.e. the system will cold start); for Nova29, the option is not ticked (i.e. the
system will warm start).

· Default names - tick this checkbox to apply default names whenever you add a new IO card to the
project.

· Online - tick this check box to open a network connection to the selected unit. The two traffic lights
indicate the status: green = valid connection; red = not connected; yellow = software needs updating.
Leave the Online box unticked to work offline.

· IP-Address - enter the IP Address of the selected unit. If Online is ticked, then the traffic lights should
turn green if there is a valid network connection.

· Comment (optional) - use this field to add notes about the project.

Console

The horizontal bar at the bottom of the 'Project' window shows the progress of operations such as open project,
save project, transfer config to unit, etc. 

The text area below shows what is currently occurring (e.g. Create...), and provides confirmation when a
operation has been completed.
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4.10 Checking the Network Communication

You can check your network connection to the system by opening a project and ticking the Online checkbox
(in the 'Project' window).

The two traffic lights indicate the status of the network connection: green = valid connection; red = not
connected; yellow = the Lawo system software needs updating.

Network Communication OK No Network Communication

If the traffic light is green, then there is a valid network connection, and you should see the System version in
the 'Console' area (below the progress bar).

If the traffic light is yellow, then you will need to use SoP Explorer to update the system software. 

If the traffic light is red, check the following:

· Are your network connections made correctly?

· Does the IP address entered in the IP-Address field match that of the Lawo control system? If not, you
will need to edit the address.

· If the IP-Address is correct but you still have a red indicator, then check that the IP Address and
Netmask of the Lawo control system are within the same subnet as your PC. If not, you will need to
modify the TCP/IP settings of your computer's network interface card in order to establish a valid
connection.

· If all this looks correct, then try running a Windows PING test.
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4.11 Options

1. Select View -> Options from the top menu bar, or click on the  Toolbar icon to open the 'Options'
dialogue box:

The options are divided into the following categories:

· Colors - define the field color-coding used by ON-AIR Designer.

· Metrics in pixel - define the default sizing of windows such as the Treedefinition.

· General:

o Show convert message - see Converting Projects to the Current Release.

o Font - defines the font and text size used by ON-AIR Designer.

2. In each case, make a selection and then click on OK to confirm.

3. To restore all options to the factory defaults, click on Restore Defaults.



ON-AIR Designer User Guide Version: 6.0.0/2 39/102

4. Basic Operations

4.12 Closing the Project & Software

In ON-AIR Designer, you can open multiple projects at the same time. Therefore:

1. To close the active project, select File -> Close from the top menu bar, or click on the  Toolbar icon.

2. To close the complete application (and all active projects), select File -> Exit from the top menu bar, or
click on the red cross (at the top right of the headline bar). 

In either case, if you have made a change since the last save, then you will be asked if you wish save or ignore
the changes:

· Select Save to overwrite the current project.

· Select Ignore to close the project or software without saving.

· Select Cancel to cancel the operation and continue editing.
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5.     Configuring a Single Unit

This chapter describes how to edit the configuration for a single unit. 

It is divided into three sections:

· Hardware Configuration (Part I):

o Surface

o System Core

o Panels

o Screen

o Function Pool

o Change Frame

· Hardware Configuration (Part II):

o The 'Tree Definition'

o User Levels

o Command -> Inputs/Outputs

o Programming Shortcuts

· Configuration Monitoring:

o 'Resources' Window

o Jump to...

o Parameter Line
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5.1 Hardware Configuration (Part I)

5.1.1 Surface

The Surface configuration defines the control surface modules and their parameters.

1. Click on the  Toolbar icon, or select Frame -> Surface, to open the window:

Surface Configuration Window

Note that the maximum size of the control surface is defined by the 'Frame Selection'. 

For larger frames like the one above, you may need to scroll left or right to see all the modules. To see the

complete surface (as shown above), click on the  Toolbar icon, or select Frame -> Show All Hardware. This
will show (or hide) any unused panels or surfaces.

You can zoom in (or out) on by pressing and holding CTRL while scrolling your mouse-wheel.

Each module position represents a CAN bus address within the frame. This is a unique hexadecimal address
which defines the role of each module. You can find more information about your system's CAN bus addresses in
the relevant product manual.

Can Bus Addresses (ruby)
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2. To add or change a module, right-click on a slot and choose an option from the drop-down menu.

Fader Module Assignment (ruby)

For information on the options supported by your system, please refer to the relevant product manual.

Note that the Surface configuration will not necessarily look like your physical console, as it is the CAN bus
address assigned to each module which is important.

3. Double-click on a module to open its parameter window.

These are identical to the parameters in the "Surface" branch of the 'Tree Definition'.

Fader Module Parameters (ruby)

4. Return to the Surface configuration window and locate the Central Module. Here you will see the MF Key
labels for all existing functions. Drag and drop an MF Key to swap the button functions - a "+" sign will appear
when a valid "drop" position is reached. 

Note that this operation always swaps the functionality so you will never "lose" any of your existing programming.
All connected logic is included in the swap.

Central Module - before swap Swap in Progress Central Module - after swap



ON-AIR Designer User Guide Version: 6.0.0/2 43/102

5. Configuring a Single Unit

5.1.2 System Core

The System Core configuration defines the plug-in cards and IO parameters for the DSP Core.

1. Click on the  Toolbar icon, or select Frame -> System Core, to open the window:

System Core Configuration Window

Note that the licensed package supported by the System Core is defined by the 'Frame Selection'. Therefore, if
the Core does not look as expected, please check the current specification.

You can zoom in (or out) on by pressing and holding CTRL while scrolling your mouse-wheel.

2. To add or change a plug-in card, right-click on a slot and choose an option from the drop-down menu:

Expansion IO Card Options (POWER CORE)

For information on the options supported by your system, please refer to the relevant product manual.

When you have completed all the assignments, the on-screen ‘Frame’ should look identical to your DSP
Core.
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3. Double-click on a connector to open the parameter window for its inputs and outputs.

These are identical to the parameters in the "Audio Input -> IO Card" and "Audio Output -> IO Card" branches of
the 'Tree Definition'.

MADI Port 1 Input Parameters (POWER CORE)

4. Return to the System Core configuration window and:

· Double-click on the text DMS to access the DMS elements (used for VisTool metering or to create audio
loopbacks). 

· Double-click on the text GT to access the GT In/Out elements (used for GPIO-over-Audio).

These are identical to the parameters in the "Audio Input -> DMS & Loopbacks" and "GPIO -> GT In/GT Out"
branches of the 'Tree Definition'.
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5.1.3 Panels

The Panels configuration defines any Key Panels which may be connected to your system and their parameters.

1. Click on the  Toolbar icon, or select Frame -> Panels, to open the window:

Panels Configuration Window

If this is a new configuration, then you will see a series of blank 19” frame panels. The maximum number of Key
Panels is defined by the 'Frame Selection'.

2. Right-click on an empty panel slot to assign a Key Panel:

For information on the options supported by your system, please refer to the relevant product manual.

3. Repeat to assign all the Key Panels connected to your system.

Panels Configuration (example)

Panels are addressed from top to bottom according to their CAN bus address.

You can zoom in (or out) on by pressing and holding CTRL while scrolling your mouse-wheel.
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4. Double-click on a panel to open its parameter window.

This accesses the same parameters as from the "Panel"  branch of the 'Tree Definition'.

KS-16 Key Panel Parameters

5. Return to the Panels configuration window and note that the MF Key labels are shown for all existing
functions. Drag and drop an MF Key to swap the button functions - a "+" sign will appear when valid "drop"
position is reached. 

This works in a similar manner to the Central Module MF Key swap described earlier.
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5.1.4 Screen

The Screen configuration can be used to create virtual control panels which will be operated from VisTool. Note
that the number and type required will depend on your plans for VisTool. Please refer to the separate "VisTool
MK2 User Guide" for more information.

1. Click on the  Toolbar icon, or select Frame -> Screen, to open the window:

Screen Configuration Window

You can zoom in (or out) on by pressing and holding CTRL while scrolling your mouse-wheel.

2. Right-click on an empty panel slot to assign a Screen Panel:

The available options are:

· Matrix 128 * 128 Control - an XY matrix panel of 128 x 128.

· Matrix Control - an XY matrix panel of 90 x 30 (switched in pages).

· Screen Blank Panel – a blank cover plate.

· Screen Button – 32 MF Key functions.

· Screen Button RGB – 64 MF Key functions with self-labelling, RGB buttons.

3. Scroll down to the lower slots and notice that some additional options become available:

Slot 11: Screen Matrix TB - a talkback switching panel, with 32 buttons:
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Slot 12: Screen Matrix Monitor - a monitor matrix control panel, with 32 buttons:

Slot 13: Network Assign - a network assign control panel, with 32 buttons:

Slot 14: Screen Src Assign - a fader strip assign control panel, with 32 buttons:

Slot 15: Parm Control - a DSP control panel, with 32 buttons:

4. Double-click on a panel to open its parameter window. 

This accesses the same parameters as from the 'Tree Definition'.

5. Note that Panels configuration window shows the MF Key labels for all existing functions. Drag and drop
an MF Key to swap the button functions - a "+" sign will appear when valid "drop" position is reached. 

This works in a similar manner to the Central Module MF Key swap described earlier.
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5.1.5 Function Pool

The Function Pool is only available for ruby. It can be used to prepare MF Keys before positioning them on a
Central Module, or to move a function by swapping it to and from the 'Function Pool' panel. This is ideal if you
know what functionality is required, but are not yet sure of the MF Key layout.

1. Click on the  Toolbar icon to show or hide the 'Function Pool'.

The window can be floating or docked to one side (left or right). See Arranging the Workspace.

2. Double-click on any MF Key in the window to open the Function Pool parameter window. 

This shows all the dummy MF Keys available. Each one can be programmed in the usual manner:

3. Now open the Surface configuration and drag and drop the MF Key from the Function Pool to the Central
Module - a "+" sign will appear when a valid "drop" position is reached. 

You can use the same drag and drop technique to move functions to and from the Function Pool panel. This
allows you to easily rearrange an existing MF Key layout.



ON-AIR Designer User GuideVersion: 6.0.0/250/102

5. Configuring a Single Unit

5.1.6 Change Frame

The Frame selection can be used to change the maximum specification of the system.

1. Select Frame -> change frame to open the dialogue box:

Frame selection window

Here you can specify each of the system components: System Core, Surface, Panels or Screen as described
earlier.

2. If you change an option, click on OK - the software now loads the hardware configuration for the new
frames. 

Note that it may take a few seconds to load the data. During this time the status is shown in the "progress" bar
(below Console in the 'Project' window).
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5.2 Hardware Configuration (Part II)

5.2.1 The 'Tree Definition'

The 'Tree Definition' is the main programming tool and is used to define elements and their parameter options.

1. Click on the  Toolbar icon, or select Command -> Treedefinition, to open the window.

Note that the 'Tree Definition' can be opened multiple times to access different branches of the system tree. The
window(s) can be floating or tabbed. See Arranging the Workspace.

Below is an example taken from a customer project.

Treedefinition: Source -> Parameter branch (POWER CORE)

System Tree

The ‘Tree Definition’ gets its name from the tree-like structure on its left hand side. Each of the branches can be
opened by double-clicking on a branch name or on the arrows beside the branch. Once open, you will see all
configured elements.

Some elements are automatically added to the 'Tree Definition'. Others, such as Source, Sum Bus and Logic
elements must be inserted. Right-click on a branch to Insert, Copy or Delete an element. If an element does not
exist within the System Tree, then it is not configured. In our example, the Source branch is open; the sources
have been organised into groups named Desk, Kommando, etc. Within the Mikrofone group, 15 mono sources
have been added.

Select Command -> Sort Tree to sort elements within the system tree alphabetically.

Parameter Area

When you open up a branch of the tree and select an element, its parameter options appear on the right hand
side. In our example, we can see the parameters for the source named Co_HS.

Some parameters are linked to other elements within the configuration - for example, the source's Audio Input
and control functions such as Input Mute, Fader Up/Down, etc. Note that these fields are colour-coded to
indicate that they are linked: pink for an audio input or output; green for a logical function; etc.

For some elements, there will be more than one page of parameters. If so, these are accessed by tabs at the top
of the window - in our example, Parm, PFL, Conf, DownSrc, Aux, Aux Switch and Keys.
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5.2.2 Inserting Elements

To add a new element to the configuration:

1. Right-click on the appropriate branch of the system tree - e.g. Source - and choose Insert Element.

2. Select the type of element you want to add - in our example there is only one option: Source.

3. On the right, place the element within a Group, for example Mikrofone.

Groups are used to categorise elements so that, as your configuration develops, it is easy to track them
down to make changes. For example, you might put all of your on-air sources into the OnAir group, all your
playbacks into the Machines group and so on.

4. Enter the number of elements of the same type you wish to create in the Iteration box.

5. Then click on OK - the new element(s) are added to the system tree under your selected Group category.
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5.2.3 Naming Elements

After adding an element to the ‘Tree Definition’, you must name it. It is this reference name which will be used to
link to other elements within the configuration.

Reference names MUST be unique. Choose your reference names carefully so that you can easily locate
functions as the configuration grows.

For our example:

1. In the Source field, enter a reference name. 

It is best to use short names to keep the configuration simple.

Once entered, the Reference name appears beside the element in the system tree:
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5.2.4 Editing Parameters

The parameters for the selected element are edited on the right hand side of the display; the available parameters
depend on the product and user mode:

To help quickly identify links to other elements, the parameter fields are colour coded as follows:

· White = text entry, value or checkbox.

· Green = link to/from a logical function.

· Pink = link to/from an audio input or output.

· Blue = link to/from a source.

· Brown = link to/from a summing bus.

· Yellow = link to/from a level or balance function.

· Orange = link to/from a label.

· Magenta = link to/from the state of another element.

1. For white entry boxes, either type in the text or value required, or tick the checkbox to enable the option.
Press Backspace on your PC keyboard to remove unwanted text from an entry.

You can use keyboard shortcuts such as F5 (copy) and F7 (incremental paste) to speed up the data entry -
for example, to enter MIC01, MIC02, MIC03, etc. into the source name fields.
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2. For coloured entry boxes, double-click inside the box to open a 'Tree Selection' window - in our example,
we have double-clicked inside the pink Audio Input box.

Different ‘Tree Selections' appear depending on the parameter you are assigning. For example, you will see
only audio signals when assigning a pink entry box; only control signals when assigning a green entry box;
and so on.

3. Open the branches of the 'Tree Selection' to choose an input:

4. Select OK to confirm and close the 'Tree Selection' window - the parameter box updates to show your
assignment.

5. To remove a linked entry, click anywhere inside the entry box and press DEL on your PC keyboard. (You
cannot use Backspace.)
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5.2.5 Working with Control Signals

When programming logical functions (green parameter entry boxes), it is important to understand the control
signals available from the 'Tree Selection':

Ø  Control Inputs

Logical functions may be triggered from any input control signal:

· GPI/O – any GPI. 

· MF Key – any MF Key including those on a Key Panel or VisTool screen display. 

· Logic – a logical element such as an OR gate, AND gate, Toggle Flip Flop.

· Surface – the alarm contact from any module within the Surface. 

· Panel – the alarm contact from any Key Panel.

The following example shows how to configure an MF Key to open and close a fader.

1. Select the Source from the system tree and double-click in its green Fader Toggle box to open the
'Tree Selection' window. 

2. Then select the desired control signal - in our example, the Source's MF 1a Key - and OK:

Once this configuration is transferred to the system, you will be able to open and close the Source from the fader
strip's MF Key 1a.
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Ø  Control Outputs

Most elements offer control outputs. These reflect the status of the element and may be used to configure a
return operation - for example, to light the fader start MF Key when the Source fader is open.

1. With the same Source selected, select the Keys tab to view the Source's MF Key lamps and labels. For
each MF Key, you may define up to 8 key states labeled P1 to P8 – P1 is lowest priority; P8 is highest priority.

2. Double-click on one of the key state Logic boxes to open a ‘Tree Selection’ window.

3. In the 'Tree Selection', open the the Logic -> "Source Group" -> "Source Name" branch and assign the
source's Fader Start control signal:

4. Now select a colour for this state by clicking on the drop-down Color menu - we have selected red.

In this example, we have created an MF Key which will open the fader, and turn red when the fader is open. 

Note that the MF Key's P1 state has also been configured so that the key lights in green when the fader is closed
(using nFader start).
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Ø  Logic Elements

Sometimes you may want a function to be triggered from the logical result of a number of other conditions. For
example, to trigger a Red Light if any one of a number of Sources are "on-air". 

For this application, you could use the OR8 Logic element as follows:

1. First insert and name an OR8 element under the Logic branch of the 'Tree Definition'.

2. Double-click in the In 1 box to open a ‘Tree Selection’ window.

3. In the 'Tree Selection', open the the Logic -> "Source Group" -> "Source Name" branch and assign the
source's Channel On control signal:

4. Repeat to assign the Channel On control signals from the other microphone Sources.
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5. Assign the output of the Logic -> OR8 to the "On Air" light - for example, via a GPIO card:

Once the configuration is transferred to the system, when any of the four MIC Source faders are open, the Red
Light should illuminate!

Logic elements can be connected together in order to create exactly the right control signal for a function.

It is a good idea to regularly save, transfer and test your configuration as the software does not check for
feedback loops within your programming. 
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5.2.6 Programming an MF Key

MF Keys are programmed in a similar manner. In each case, you must name the MF Key, then programme its
functionality, and then define how the MF Key will light.

The example below shows how to create a monitor source selector using a TConn64 element. 

First, each of the monitor source selector MF Keys must be named - in our example, the selections are to be
made via VisTool and so the MF Keys can be found under a Screen Button RGB Module element:

Once the MF Keys are named, they can be assigned to a function - in our example, to the input Trigger of a
TConn64:
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The output of the TConn64 can then be assigned to light the MF Key lamp: 

This example will route a pair of audio inputs to the TConn64 output when the corresponding VisTool MF Key is
active, and light the MF Key in red.

In our example, a TRUE.Out control output has been assigned to the MF Key's P1 state. This is usually
programmed using a NOT logic element. The result is that the MF Key will remain Black until its function
becomes active.

5.2.7 Swapping MF Keys

MF Key functions can be swapped in a similar manner to the Central Module MF Key swap described earlier.
However, this time you must drag and drop on the MF Key's Reference name to perform the swap - a small arrow
will appear when a valid "drop" position is reached:

MF Key - swap in progress

Alternatively, you can use F11 and F12 as follows: select the first MF Key name field and press F11 (to mark the
active MF Key). Then click on another MF Key name field and press F12 - this swaps the two MF Key functions. 

In both cases, all connected logic is included in the swap.
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5.2.8 Copying Elements

If you have a number of elements (e.g. Sources) which require similar parameters, then Copy Element can save
a lot of programming time.

1. First insert, name and configure the element with all the common parameters you wish to copy.

2. Then right-click on the element in the system tree and choose Copy Element:

3. Select a Group for the new elements, for example Ltg.

4. Enter the number of copies you wish to make in the Iteration box, for example 3.
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5. Click on OK - the copied elements now appear under your chosen group category.

Note that the copied elements are marked with an * to distinguish them from your original element. Any logic
signals that are referenced to the original element are also marked with a * - in our example, the MF Key
assigned to the Ch On/Off Toggle field.

6. Your first task is to change the Reference name for each copy - this updates both the element name and
any referenced fields.

7. You can now make individual changes to the copies. 
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5.2.9 Deleting Elements

Elements can be deleted individually (as described below) or in multiples (using Clean).

 To delete an individual element:

1. Right-click on the element in the system tree and choose Delete Element:

2. Confirm by clicking on Yes, or select No to cancel.

5.2.10 Clean

The Clean function can be used to delete multiple elements. It works by deleting all elements within the system
tree which are unnamed.

1. First select each element and clear its Reference name from the parameter area.

2. Repeat for all the elements you wish to delete:

Reference Name cleared Reference Names cleared for multiple Sources

3. Then right-click on any element in the system tree and choose Clean.

4. Confirm the operation by clicking on Yes - the system will now delete all unnamed elements.
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5.2.11 Groups

Grouping elements will help you find functions quickly and easily once the configuration begins to grow. You can
create your own group categories in addition to the ones included with the software.

Ø  To add a new group:

 1. Right-click on any element in the system tree and choose Insert element - the ‘New element’ window
opens.

 2. Select New and enter the new group name:

 3. Select OK - the new group is added to the bottom of the list.

Ø  To delete an existing group:

1. Open the ‘New Element’ window as described above.

2. Select the group(s) you wish to delete and click on Delete.

3. Confirm by clicking on Yes or select No to cancel.

If the group already contains elements it is not possible to delete the group.

Ø  To rename an existing group:

1. Right-click on an element in the group you wish to edit and choose Rename Group - a dialogue box
opens.

2. Enter the new name for the group and confirm the change by clicking on OK.

Alternatively, you can open the 'New Element' window as described above and use the Rename function.

Ø  To change the group of an existing element:

1. Right-click on the element in the system tree and choose Change Group - the ‘New element’ window
opens.

2. Select the new group and confirm the change by clicking on OK.
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5.2.12 Find

The Find function can be used to search the system tree by name. It is very useful for finding elements or
functions within a larger configuration.

1. Right-click on any element in the system tree and choose Find, or select File -> Find from the top
menu bar, or use the keyboard shortcut (CTRL + F) - the 'Find..' dialogue box opens.

The Find function cannot be selected unless there is an open 'Tree Definition' window.

2. Enter the name you wish to search for. The search is not case sensitive.

3. Click on OK - the system now searches and all matches are highlighted in red:

4. You can now select a match to interrogate the element further.

Note that the current search remains active until you re-open the 'Find' dialogue box and clear its contents.
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5.2.13 User Levels

The configuration possibilities are vast and so, to simplify the software, there are four user modes. 

1. Click on the on the  Toolbar icon to check or select a user mode:

The user mode affects what options you see within the ON-AIR Designer:

· System – this mode is for Lawo personnel only; it is used for testing new configuration options.

· Expert – in this mode you have full access to all configuration options. 

· Advanced – provides a higher level of access to configuration options. For example, if you wish to
configure the unit to lock to Wordclock sync.

· Basic – this is the default mode. In this mode you can make minor changes to the configuration like
renaming a source label. All other configuration options are locked.

WARNING: In System or Expert mode, it is possible to break the system’s functionality by transferring a
badly programmed configuration! Therefore, your system warranty may be affected if you re-configure the
system using either of these modes.
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5.2.14 Command -> Inputs/Outputs

The Command -> Inputs and Command -> Outputs windows can be used to view and edit IO parameters in list
form. This is often easier than using the 'Treedefinition'.

1. Select Command -> Inputs from the top menu bar, or click on the  Toolbar icon - the 'Inputs' list
opens:

Here you will see all inputs to the system including any loopbacks.

The ID number on the left is fixed and is the unique matrix address number for the input.

Any grey boxes are for reference only and cannot be adjusted. White boxes allow you to click and edit a
parameter value.

2.  Click on a white parameter field to edit its value - some options allow text entry; others offer a drop-down
menu or an enable/disable checkbox.

3.  Click into another field (or press TAB) to confirm the new entry.

The parameter options are identical to those available from the IO branches of the ‘Treedefinition’: "Audio Input",
"Audio Out Only" and "Audio Output".

You can use keyboard shortcuts such as F5 (copy) and F6 (paste) to speed up the data entry.
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Resizing & Sorting the Lists

1. Click and drag on the column width to resize a column.

2. Click on the column heading to sort the list - when a sort is active, the column heading is colour coded. 

Keeping clicking on the column heading to cycle through the options:

· Sort list alphabetically from A to Z

· Sort list in Reverse, alphabetically from Z to A

· Sort list off.

You can click on more than one column heading to sort by multiple fields:

Command -> Inputs (Sorted by Slot AND Name)

3. Click on all coloured column headings to turn sorting off - the lists revert to sort by ID.



ON-AIR Designer User GuideVersion: 6.0.0/270/102

5. Configuring a Single Unit

5.2.15 Programming Shortcuts

Advanced Editing Functions

The copy/paste and swap functions can be used to speed up data entry in the 'Treedefinition' and 'Command ->
Inputs/Outputs' lists.

To view the available functions, right-click on a property field (in the Treedefinition) or cell (in the Inputs/Outputs
lists). Note that Copy/Paste Block is only available in the Inputs/Outputs.

Copy & Paste Cells

The following can be used to copy and paste individual cells:

· F5: Copy active cell (Inputs/Outputs) or field (Treedefinition).

· F6: Paste the copied content to the active cell; you must select the destination cell first. Following the
paste, the next cell of the same type becomes active. Press F6 repeatedly to copy the same content to
multiple cells.

· F7: Like F6, but the last number in the copied string is increased by one. This is useful for entering
incremental names such as MIC01, MIC02, MIC03, etc.

· F8: Like F7, but the last number in the copied string is increased by two. This is useful for dealing with
stereo elements - for example, to incrementally assign the left audio channels of a Priconnect.

Copy & Paste Blocks

The following can be used to copy and paste a block of cells in the Inputs/Outputs lists; it is not available in the
Treedefinition.

· F9: Copy a marked block of cells (in the Inputs/Outputs list).

· F10: Paste the copied block relative to the active cell (to the right and down).

To mark the block: click in the first cell; press and hold SHIFT, and click in the last cell - the marked block is
highlighted. You can select cells across multiple columns if you wish.

When using F10, the copied block is pasted from the active cell across cells to the right and downwards.
Therefore, take care to select the upper leftmost cell before pressing F10.

Swap Cells

The following can be used to swap audio inputs or outputs:

· F11: Mark the active line (Inputs/Outputs) or IO name (Treedefinition) to be swapped.

· F12: Swap the active line (Inputs/Outputs) or IO properties (Treedefinition) with the previously marked
contents.

Note that the functionality of the input or output remains the same; only the IO numbers are swapped.

You can use a similar method to swap MF Keys in the Treedefinition, see Swapping MF Keys.
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Other Keyboard Shortcuts

· CTRL + O: Open Project.

· CTRL + SHIFT + O: Open Last Project

· CTRL + N: New Project

· CTRL + F: Find (Treedefinition)

· CTRL + S: Save Project

· CTRL+ SHIFT+ S: Save As

· CTRL + click on reference field: Show active reference in 'Treeselection'
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5.3 Configuration Monitoring

5.3.1 'Resources' Window

The 'Resources' window can be used to check the amount of DSP resource used by the project.

1. Select Command -> Resources to display the window:

The counters show how many resources you have left out of the maximum available. Note that the resource
counters will vary depending on the frame selection for the System Core, see Change Frame.

If, during programming, you try to add a resource which exceeds any of the limits above, the software will warn
you with a ‘No resources available’ pop-up.
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5.3.2 Jump to...

The "Jump to.." function can be used in the 'Treedefinition' to find all occurrences of a reference including its
connections.

1. Right-click on a reference field and choose Jump to.. - the 'Jump to' docking panel appears.

The window can be floating or docked in any position. See Arranging the Workspace.

The Jump to.. list shows the origin of the reference (in light green); the selected reference (in dark green); plus all
other usages (in white).

Note that any elements containing the reference are also highlighted in the system tree (in red).

 2. Click on an entry in the list to "jump to" the element containing the reference.

 3. You can use the Automatic update option to update the Jump to.. list as follows:

· Automatic update (on) = the Jump to.. list updates when you select a different reference.

· Automatic update (off) = the Jump to.. list does not update and continues to list all entries for the initial
reference.
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5.3.3 Parameter Line

You can use the Parameter Line function in the 'Treedefinition' to open a single docking panel containing all the
parameter's options. This is helpful when editing a parameter that has lots of options such as a RAVENNA
output.

1. Right-click on the parameter you wish to interrogate and choose Parameter Line - the 'Parameter line'
docking panel appears.

The window can be floating or docked in any position. See Arranging the Workspace.

The docking panel shows all the options for the selected parameter. In our example, this makes the RAVENNA
output options more visible and avoids having to scroll left and right across the parameter line.

 2. You can use the Automatic update option to automatically update the Parameter line docking panel:

· Automatic update (ticked) = the docking panel updates to show the parameter in focus.

· Automatic update (not ticked) = the docking panel does not update and continues to show the initial
selection.
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6.     Transferring Configuration Data

This chapter describes how to transfer the configuration to a unit.

Topics include:

· Preparation

· Transfer -> Config to unit

· Transfer -> Setup to unit

· Load Project from Unit

· Transfer -> Create Config
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6.1 Preparation

To check your programming you will need to transfer the configuration data to the Lawo system. Note that, for all
products except ruby, you must transfer the setup data first and then the configuration.

During the transfer, you can choose to save the project file onto the DSP Core (if your system supports this). This
allows you to store the system configuration on the unit, and load it to another computer at a later date.

Note that:

· If the project contains more than one unit, then you must repeat the transfer for each unit.

· At the end of the transfer, the DSP Core will restart. Therefore, you should make sure that the system is
NOT in use before starting the transfer.

· The transfer will replace the existing configuration stored on the control system. Please make sure you
have a backup of the existing project before proceeding.

· When running with a firewall, it may be necessary to allow Firewall access for the ON-AIR Designer,
before you can transfer settings from your computer.

· You must save your project before transferring configuration data (to allow the required binary files to be
created).

In all cases, the first steps are to connect the configuration PC to the Lawo control system and check the
network communication. See Connecting Your PC to the Lawo Control System and Checking the Network
Communication.
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6.2 Transfer -> Config to unit

This function transfers the configuration parameters to the selected unit.

1. Open the project you wish to transfer.

2. In the 'Project' window, select the unit from the Units field (if configuring multiple units).

3. Then tick the Online checkbox and make sure that you have a valid network connection to the system.

If not, then edit the IP-Address field to match that of the Lawo control system - the traffic light should turn green
(as shown below).

If you need to change the unit's IP address, then use Transfer -> Setup to unit (all products except ruby) or the
POWER CORE's Web UI interface (ruby only).

4. If you have made any changes to the configuration, then these must be saved before the configuration is
transferred.

Use either File -> Save or File -> Save As to save the project. You can use any file name and location, as long
as the file type (.db3) remains unchanged.

4. Select Transfer -> Config to unit from the top menu bar, or click on the  Toolbar icon:

If the option is greyed out, then this is because there is no network communication between your PC and the
control system.

5. At the confirmation box, select Yes to start the transfer:

Note that for POWER CORE and Nova17, the confirmation box includes an option called Save Project to Unit.
You can use this to include a copy of the ON-AIR Designer project file in the transfer.
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The software now creates the necessary binary configuration files, and transfers them to the Lawo control system
via the Ethernet network.

The progress of the transfer is shown in the Console status area at the bottom of the 'Project' window. Once the
transfer is complete you will see the lines File loaded to unit and Sending Restart. The system may take a
few seconds to restart. Once boot-up is complete, the new configuration parameters should be valid.

Project Save + Binary Files Creation Files Transferred to Unit

If your computer’s firewall prevents the transfer, then change your firewall settings and retry.
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6.3 Transfer -> Setup to unit

This function applies to all products except ruby. It transfers the setup parameters defined in the 'Project' window
to the selected unit, and must be performed before using Transfer -> Config to unit.

1. Open the project you wish to transfer.

2. In the 'Project' window, select the unit from the Units field (if configuring multiple units).

3. Then tick the Online checkbox and make sure that you have a valid network connection to the system:

If not, then either edit the IP-Address field to match that of the Lawo control system - the traffic light should turn
green (as shown above).

Or, if you wish to transfer a new IP address to the unit, then edit the IP-Address field and leave your cursor within
the field - the field turns red. When you now save the project and transfer the setup data, the new IP address will
be part of the new information sent.

WARNING: If you leave your cursor in a red IP-Address field, and then perform a Transfer -> Setup to unit,
you will transfer the new ‘Project’ window IP Address to the system.

4. If you have made any changes, then these must be saved before the configuration is transferred.

Use either File -> Save or File -> Save As to save the project. You can use any file name and location, as long
as the file type (.db3) remains unchanged.

5. Select Transfer -> Setup to unit from the top menu bar:

If the option is greyed out, then this is because there is no network communication between your PC and the
control system. Or, your product does support the independent transfer of setup data.

6. At the confirmation box, select Yes to start the transfer.
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The software now creates the necessary binary configuration files, and transfers them to the Lawo control system
via the Ethernet network.

The progress of the transfer is shown in the Console status area at the bottom of the 'Project' window. Once the
transfer is complete you will see the lines File loaded to unit and Sending Restart. The system may take a
few seconds to restart. Once boot-up is complete, the new setup parameters should be valid.

If your computer’s firewall prevents the transfer, then change your firewall settings and retry.

If you have transferred a new IP address to the unit, then you may need to edit your PC's TCP/IP settings in order
to re-establish network communication.
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6.4 Load Project from Unit

This function is available on POWER CORE and Nova17 only. It allows you to transfer a copy of the ON-AIR
Designer project file to the DSP Core, so that it may be loaded to another computer at a later date.

The Save Project to Unit option appears in the Transfer -> Config to unit confirmation box (if supported by your
system). If you tick the option, then a compressed version of the project file (.db3 or .mdb) will be transferred to
the unit.

To download a project which has been previously transferred:

1. Select File -> Load Project from unit:

If this option is greyed out, then there is no network communication between your PC and the control system.

2. A pop-up appears - enter the IP Address of the control system, and press the TAB key to establish the
connection.

3. Then select OK - the project file is downloaded from the unit.

4. To save the project, use Save As and enter an appropriate filename in the usual manner.
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6.5 Transfer -> Create Config

This menu option (and Toolbar icon) will create the binary configuration files without performing a transfer to the
system. It can be used when working offline to prepare files before connecting to the system.
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7.     Configuring Multiple Units in a Single Project

This chapter describes how to edit the configuration for multiple units using a single project.

Topics include:

· Overview

· Adding & Deleting Units

· Navigating Between Units

· Individualizing the Parameters of a Unit

o Adding a New Subtitution

o The Substitutions List View

o Linking Parameters to an Existing Substitution

o Deleting a Substitution from a Parameter

o Other Functions
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7.1 Overview

Using ON-AIR Designer, it is possible to configure multiple units of the same product in one project. This makes it
easy to maintain the configuration as, if something changes, the change need only be applied once. 

Once you have defined multiple units, then by default, all configured parameters apply to all units without
exceptions. You can then individualize each unit using the so-called "Substitutions" feature. Substitutions can be
applied to both the 'Treedefinition' and 'Project' window parameters. For example, to individualize the unit's IP-
Address, Deskname, etc. Once defined, substituted parameters are indicated by a grey background. 

Note that the hardware configuration (Frame -> Surface, Frame -> System Core, etc.) cannot be individualized.
However, it is possible to configure the maximum configuration required and then only use the necessary subset
of parameters per unit.

Note also that a project containing substitutions must be saved as a .db3 file and, therefore can only be used to
configure systems running V6.0.0.x or later.
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7.2 Adding & Deleting Units

Multiple units can be added to, or deleted from, the project via the 'Project' window.

Ø  To add a new unit:

1. Right-click anywhere inside the Units field and select Add unit - the new unit is added to the bottom of
the list.

Note that you may have to scroll down the list to locate its entry.

Units: Right-click New unit added

2. Double-click on the Unit name (New) to enter a more descriptive name - in our example, Studio G:

Ø  To delete an existing unit:

1. Right-click on the unit you wish to delete (e.g. Studio G) and select Delete unit - the unit is removed
from the project.
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7.3 Navigating Between Units

Once multiple units have been defined, there are two ways you can switch to a specific unit: either click on a
name in the 'Project' window Units field (shown below), or select a unit from the Toolbar:

:

Any substituted parameters within the 'Project' or 'Treedefinition' windows will update.

If you have yet to add any substitutions, then you will see no difference when you navigate between units.

If substituted parameters have been defined, then these are indicated by a grey background and they will update.
In our example below, the unit's Deskname and IP-Address have been individualized:

Selected Unit = Studio A Selected Unit = Studio C
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7.4 Individualizing the Parameters of a Unit

Within the 'Treedefinition' you can individualize any parameter.

Within the 'Project' window, the following parameters can be individualized: Deskname; IP-Address; Netmask;
Gateway; Nameserver; NTP-Server; Hostname; and Domainname.

7.4.1 Adding a New Substitution

To create a substitution, you will need to have multiple units defined. Once this is in place:

Right-click on the desired parameter and select Save as substitution:

If you open the 'Local Substitutions' docking panel, you will see a new line:

7.4.2 The Local Substitutions List

1. Click on the  Toolbar icon to open the 'Local Substitutions' list.

The window can be floating or docked to one side (top or bottom). See Arranging the Workspace.

The table lists all defined substitutions, where each line equals one substitution. On the right hand side, you will
see a column for each defined unit: EDIT 1, EDIT 2, EDIT 3, EDIT 4.

2. Click in the individual unit fields to individualize the parameter.

You can use keyboard shortcuts such as F5 (copy) and F7 (incremental paste) to speed up the data entry.

Note that the columns on the left (Group 1, Group 2, Sort, etc.) are used by the Device Configuration Wizard,
and will be described later.
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7.4.3 Linking a Substitution to an Existing Parameter

Having defined a substitution, it can be linked to an existing parameter as follows: 

· Either, drag and drop the line from the 'Local Substitutions' window onto the parameter field. 

· Or, right-click on the parameter and select Use substitution.

Once linked, the substituted parameter is indicated by a grey background, and the value for the selected unit is
displayed.

From now on, the value cannot be edited from the parameter field, but should be individualized from the 'Local
Substitutions' list as described earlier.

Note that if you switch to a different unit, via the Units list in the 'Project' window, then the displayed value will
update:

7.4.4 Deleting a Substitution from a Parameter

To delete a substitution: right-click on the individualized parameter and select Delete substitution. The
parameter is removed from the 'Local Substitutions' list and returns to its default value. It can now be edited
directly from the 'Treedefintion' or 'Project' window as a normal field.
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7.4.5 Other Functions

To interrogate a substitution: right-click on the individualized parameter and select Show substitution:

The 'Local Substitutions' list opens and sets a filter to only show the active parameter:

If you right-click on a field, then you can choose:

· Copy - duplicates the selected substitution.

· Delete - deletes the substitution (as described earlier).

· Used in.. - shows all parameters using the selected substitution in the Jump to.. docking panel. You can
step through the entries to check or modify the configuration.

Used in.. (example)
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8.     Applying Global Settings to Multiple Projects

This chapter describes how to use a global project to apply settings to multiple project files.

Topics include:

· Overview

· Defining a Global Project

· Global Substitutions

· Profiles
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8.1 Overview

A global project can be used to apply global settings to multiple project files. It is particularly useful for settings
such as color schemes, metering schemes or system levels. Whenever the global project is updated, any
changes are automatically made to all linked project files.

The global project is a normal .db3 configuration in which parameters and multiple units can be defined. Within
each "linked" project, you may then use 'Global Substitutions' instead of local ones, and/or select a profile.

The same global project can be linked to different product configurations. Providing the substituted parameters are
of an equal type, then they can be applied.

It is recommended that the global project be built and maintained at the beginning of the configuration process,
and that it stores only the global parameters to be applied to linked files.
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8.2 Linking to a Global Project

A global project can be selected in the 'Project' window: either enter the file path into the Global project field, or
click on the ... button to open a File Explorer window.

Once selected, this project is linked to the global project, and you can use its parameters as 'Global
Substitutions' and/or select a Profile.

To remove the link to the global project, clear the file path from the Global project field.
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8.3 Global Substitutions

Global substitutions behave in a very similar manner to the local ones described earlier, except you should click

on the  Toolbar icon to open the 'Global Substitutions' list.

If you transfer a configuration with global substitutions to a unit, then the linked parameters will carry their values. 

The global project itself is not transferred to the DSP Core. And, in the case of POWER CORE or Nova17, it is
not stored on the unit (if you use Save Project to unit).

When re-opening a configuration that includes a reference to a global project that cannot be found, there are two
choices of behaviour - to use the local data or not:

· If you choose Yes, then the last settings will be used, but the underlying substitutions are still saved. This
means that if the global substitutions are found later (e.g. by altering the Global project path), they will
be applied.

· If you choose No, then the substitutions will be unused and the default values will be applied. You should
choose this option only if you want to erase all existing global substitutions from a configuration.
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8.4 Profiles

In the global project, profiles are created by configuring multiple units (as described earlier). 

In the linked projects, each unit then appears as a selectable profile. This allows you to switch between different
sets of global parameters in the linked file.

To select a profile: click on the Profiles field in the 'Project' window and choose one of the drop-down options. In
our example, the profiles offer a choice of different metering schemes: DIN, UK, SMPTE, etc.
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9.     Using the Device Configuration Wizard

This chapter describes the Device Configuration Wizard. 

Topics include:

· End-user View

· Configuring the Wizard

· Display if..

· Selections
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9.1 End-user View

The 'Device Configuration Wizard' provides an alternative way to modify the substituted parameters of a single
unit. The wizard is automatically created from the substitution lists. A number of tools allow you to modify the
layout of the wizard. The instructions below describe how to open and use the wizard once it has been configured.

1. Select Command -> Device Configuration Wizard from the top menu bar, or click on the  Toolbar
icon to open the wizard:

2. Select the unit you wish to configure and click on Next.

The wizard shows all the defined substitutions for the selected unit only, and organizes the parameters into pre-
configured tabs.

3. Use the tabs to navigate around the configuration.

4. Click on a field to edit its contents.

The fields are colour-coded and can be edited in a similar manner to the 'Treedefinition'. See Editing Parameters.
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9.2 Configuring the Wizard

It is intended for an expert user to prepare the tabs and parameter fields in advance using the 'Local Substitutions'
and/or 'Global Substitutions' lists. The graphics below show how our end-user 'Device Configuration Wizard'
corresponds to the 'Local Substitutions' entry for Input 1:

Device Configuration Wizard

'Local Substitutions' - for Input 1

Each of the columns on the left is used to define how the substitution appears in the wizard:

· Group1 - defines the tab; several parameters may be grouped. A number as a prefix will not be shown in
the wizard but may be used to order the Tabs.

· Group2 - defines the headline; several parameters may be grouped. As above, a prefix may be used for
ordering.

· Sort - is used to order parameters within the headline. Parameters are ordered according to their Sort
number (from low to high).

· Linefeed - all parameters are shown on one line, unless you enable the Linefeed checkbox. If ticked,
the substitution will be displayed on a new line.

· Text - defines the parameter name shown in the wizard. By default, the text is the parameter name.

· Display if.. - is used to hide parameters in the wizard which use free substitutions in combination with
logical statements. See Display If...

· Selection - is used to limit the selection to a choice of references. See Selections.
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9.3 Display if..

Display if.. is used to hide parameters in the wizard which use free substitutions. You can define a condition
which controls whether an element is shown in the wizard using <,>, <=, >= or =. Or, define several matches
using a comma-separated list. 

The Selection field of a free substitution reference (ID) is used as the logical input. The number refers to the
element of the drop-down menu shown in the wizard, while 0 is the first element.

'Local Substitutions' - Display if.. (example)

You can also define, whether an element is used in the configuration by adding a Display if.. statement to the
name of the element in combination with the string "cfg". This permits the configuration to use the whole element,
only if the statement is true. Using this feature, you can control which sources are actually used in the runtime
(via the source selection list).

'Local Substitutions' - Display if.. (with logical statements)
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9.4 Selections

In the substitutions lists, the Selection column is used to limit the wizard's selections to a choice of references.
It can be used in conjunction with Free Substitutions or the 'Tree restriction' dialogue box.

9.4.1 Free Substitutions

Free Substitutions are used to control the visibility of other substitutions. 

To create a free substitution, right-click on the substitutions list and select New free:

You can now enter a list of strings, separated by a semicolon in the Selection column, to define the options
available in the Device Configuration Wizard. Other substitutions may then be suppressed if the Display if..
statement is not true. See Display If...

'Local Substitutions' - Free Substitutions

9.4.2 Tree restriction

The 'Tree restriction' dialogue box can be accessed by double-clicking on a Selection field. It is used to add
elements to the selectable references for the parameter. It can be used in two ways: to create selectable
references (for a drop-down list) or to filter the available selections (to limit the options visible in the 'Tree
Selection'. You can see if either of these options are active by looking in the Selection column of the
substitutions list:

· "selection" = the parameter will use selectable references.

· "filter" = the parameter options will be filtered by a Regular Expression.

Note that you may use either filters or selections; but a combination of both is not possible.
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Selectable References

If the 'Tree restriction' list contains elements, then these will be shown as a drop-down menu in the Device
Configuration Wizard.

You can add allowed elements to the list using '+', or remove an element using '-'. You can also change the order
by dragging and dropping the elements in the list. The Text column defines the reference name shown in the
wizard. If no text is defined, the Reference name is shown.

Tree restriction Device Configuration WIzard

Filters

The Filter field can be used to define Regular Expressions (RegExp) to filter the selectable references. The
hierarchical order of the references is maintained, but you can exclude unwanted references from the normal 'Tree
Selection'. Both the group/physical name and the configured name can apply to the filters. A help window can be
opened using the Help button.

Tree restriction Treeselection
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10.     Appendices

This chapter includes further information which you may find useful. 

Topics include:

· Files & Organisation
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10.1 Files & Organisation

Configuration Files

The ON-AIR Designer creates configuration files offline and saves them as database files on your computer. A
number of different files are created with different suffixes:

.db3 – this is the file which you create when you save a project, and it is this file you edit using the ON-AIR
Designer software.

.mdb – this is the format used by the previous configuration tool. It is supported for backwards compatibility
reasons.

.prm – this is the binary file which is created when you perform a Transfer -> Setup to unit. The file contains all
the setup parameters for the system and is transferred and stored on the control system.

.cfg – this is the binary file which is created when you perform a Transfer -> Config to unit. The file contains all the
configuration settings for the system and is transferred and stored on the control system.

__Kpf.mdb – this is the file which stores source and target names for inputs and outputs which are ‘matrix
enabled’. It is located in the kpf folder of the project directory.

before_convert.mdb – this is a file which is created when the ON-AIR Designer converts an existing file. It
allows you to keep a copy of the original project before conversion.

It is a good idea to create a project folder which will contain all the file types required for a particular system,
and to make backup copies of your work to avoid losing any data.

VisTool Files

In addition, if you are using VisTool Editor, you will create a .vistool file when you save the VisTool project. It is a
good idea to keep the VisTool project and the system configuration together, and name the files clearly. When
you are ready to transfer the configuration to the VisTool runtime PC, you can then copy the complete folder.

The Visconfigurations.mdb file is created when you first start the VisTool Editor software. This file is where any
PC snapshots and user rights management data created by a VisTool are stored.  Normally, you would use one
Visconfigurations.mdb file on each VisTool PC. However, if you wish to network snapshots between VisTool
PC’s, then copy one of the original Visconfigurations.mdb files to a shared location and point all VisTools to
this database. When you first start VisTool Editor, you will be asked for the file location; following a standard
install, the Visconfigurations.mdb file is automatically saved at:

c:/ProgramData/DSA/VisToolMK2/database\Visconfigurations.mdb

In Windows 7, this file path may be hidden from view. If so, use Windows Explorer to show your hidden files and
folders.
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